Replies: 1 (Who?), Viewed: 327 times.
Test Subject
Original Poster
#1 Old 5th Mar 2021 at 11:03 PM
Default mesh has odd shadows on it?
hi! im currently learning how to convert ts4 clothes to ts3 and ive run into a bit of a problem. everything looks absolutely fine in tsrw, but in game the mesh has really bizarre shadows and almost looks velvety. i've tried googling this issue and that lead me to smoothing the vertices in blender, flipping the normals, etc all of which didn't help the problem. i've come across this in every piece of clothing ive tried to convert and i really dont know where im going wrong
Screenshots
Advertisement
Alchemist
#2 Old 9th May 2021 at 5:25 PM
While you are working, make sure the "Auto smooth" option under the Groups tab is not enabled! That messes with the normals.

Try this:

Open mesh in Milkshape.
Enlarge it on all axes by 10000, by Origin.
Select All (Ctrl-A), Weld (Ctrl-W).
Run Model Cleaner. Select "No" to the prompt asking you whether to separate the vertices or not.
Scale your mesh by .0001, by Origin.
Go to Tools -> Sims2 Make Unimesh Smoothing Groups. Let it finish. Your mesh should look dark.
In the Groups tab, under Smoothing Groups, make sure the Select button is active.
Click on button 2, press V (align normals). It should look OK. If you run into issues where there is a black shadow along the edge of the piece, see this guide.
Click on button 3, press V and so on until you have no more smoothing groups to correct.
Select all (Ctrl-A), click the Assign button, then click on the button 1. Now you will have a single smoothing group.

Hopefully that should fix it, but if you have any issues feel free to ask

Tumblr | CC reuploads / creator backups | TS3 CAS Conversion Catalog - for basegame, EP, SP, and Store clothing!
Back to top